DynDeveloper.com

DynDeveloper.com

Sign Up Now!Log In
xenitel 8/12/2014 5:12:58 PM

GP Web Services authentication issue

I have (I believe) an authentication issue.  Trying to use GP Web Services to push data into a GP database.

I have GP (2013), GP Web Services, and SQL Server (2008 R2) installed on one server, and I am hooked into the Web Service through VS2012 on a separate machine.  

I have been able to retrieve data using the GetCompanyList() method; but any method requiring a policy object fails at the point of retrieving the policy object with GetPolicyByOperation() (I've tried with CreateCustomer() and CreateSalesInvoice() ).

I have been working with four different accounts -- DYNSA, sa, GPServices, and my AD user account.  As far as I can tell, I have configured all four accounts with full access to SQL Server, GP, and GP Web Services.  Nevertheless, I'm pretty sure that I have something configured wrong with one or all of these accounts.

I get two different error sequences, depending on which account I assign to the DynamicsGPClient object.  Sequence one returns a client-side exception message "The caller was not authenticated by the service.", and nothing on the server.  This guy had the same issue, but no one ever responded.

Sequence two returns the generic client-side "unhandled system exception" message, and on the server side (in the Dynamics Exception Console) I get "Microsoft.Dynamics.Security.NonExistentSecurityObjectException : The security object does not exist.  Key = 0".  It's my understanding that "Key = 0" refers to the Company ID.  Our test company is ID 1, and that is definitely the value I am assigning in the Context parm ... so why the server is looking for Key 0, I don't know.

Thanks in advance for any help.

Version: GP 2013
Section: Dynamics GP, Web Services